Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Hasta las narices de Homeassistant
#1
Hola, muy buenas.

Despues de estar horas y horas (con inestimables ayudas de foreros) para poder instalar o mejor dicho...poder integrar Homeasistant en Google Home, por fin pude controlar
un encendido desde comandos de voz por el altavoz de google, pero ahora viene el quebradero de cabeza. En el archivo swtich.yaml cuando creas mas de un switch (por lo menos a mi)
luego cuando entras en el resumen de homeassistant solo aparece el ultimo que cree, y asi me he podido estar horas y horas, quitando espacios, cambiando caracteres, copiando y pegando
procedimientos aqui explicados, buscando en google, en Español, en Ingles (parece ser que nadie tiene este problema) y....nada de nada.
Para estar asi con homeassistant es mejor dejar el proyecto, pq es q no me deja crear otro interruptor, incluso desde otro arduino en otro bus, siempre es lo mismo, te aparece el ultimo que le cargas, y la verdad es que ya me esta cansando este tema, pq lo q mas me desespera es que empezando desde el principio a configurar un modulo Nodemcu, pasando por llamar a la operadora para que me cambiaran de IPv6 a IPv4 y todas las configuraciones realizadas con exito, para que ahora por un simple archivo no funcione nada.

La ultima configuracion que cargue al switch.yaml fue esta que pego un compañero del foro:

platform: mqtt
name: “Lampara”
state_topic: "domuino001/get/luzmesa"
command_topic: "domuino001/set/luzmesa"
payload_on: "1"
payload_off: "0"
qos: 0
retain: true
platform: mqtt
name: “Puerta”
state_topic: "domuino001/get/luzpuerta"
command_topic: "domuino001/set/luzpuerta"
payload_on: "1"
payload_off: "0"
qos: 0
retain: true

Ya he probado con todo, ni con todo junto,ni con guiones, ni separado, ni nada, siempre me sale el de abajo "Puerta", la "Lampara" desaparece si añado el segundo switch. Lo he mirado todo, letra por letra, numero por numero y  nada.

A nadie mas le pasa esto??? Le disteis alguna solucion si os paso o abandonasteis.....Lo digo pq hay muy poca informacion por Internet reportando este fallo.

Un saludo a todos y muchas gracias.
Responder
#2
Hola Javier.

Todos en algun momento hemos pasado por tu estado de ánimo o al menos parecido, porque todos nos hemos encontrado con problemas desesperantes. Pero al final siempre se encuentra la solución y tu caso no va a ser menos.

Me gustaría que pusieras el archivo switch.yaml entero tal como lo tienes ahora, o al menos cópialo aquí desde la primera línea a la última.
Responder
#3
(01-20-2019, 09:46 AM)Latibon escribió: Hola Javier.

Todos en algun momento hemos pasado por tu estado de ánimo o al menos parecido, porque todos nos hemos encontrado con problemas desesperantes. Pero al final siempre se encuentra la solución y tu caso no va a ser menos.

Me gustaría que pusieras el archivo switch.yaml entero tal como lo tienes ahora, o al menos cópialo aquí desde la primera línea a la última.

Gracias Latibon.

La ultima configuracion del archivo switch.yaml es la que pegue en mi primer comentario y ahi me quede.

Gracias de nuevo.
Responder
#4
(01-20-2019, 11:33 AM)javiermb escribió:
(01-20-2019, 09:46 AM)Latibon escribió: Hola Javier.

Todos en algun momento hemos pasado por tu estado de ánimo o al menos parecido, porque todos nos hemos encontrado con problemas desesperantes. Pero al final siempre se encuentra la solución y tu caso no va a ser menos.

Me gustaría que pusieras el archivo switch.yaml entero tal como lo tienes ahora, o al menos cópialo aquí desde la primera línea a la última.

Gracias Latibon.

La ultima configuracion del archivo switch.yaml es la que pegue en mi primer comentario y ahi me quede.

Gracias de nuevo.

Si tienes bien declarado el switch.yaml en el configuration.yaml con el correspondiente include, y el switch.yaml solo tiene lo que has puesto aquí, debería funcionar correctamente.

Te paso como debería quedar. Copialo tal cual respetando los espacios.



Código:
 - platform: mqtt
   name: “Lampara”
   state_topic: "domuino001/get/luzmesa"
   command_topic: "domuino001/set/luzmesa"
   payload_on: "1"
   payload_off: "0"
   qos: 0
   retain: true

 - platform: mqtt
   name: “Puerta”
   state_topic: "domuino001/get/luzpuerta"
   command_topic: "domuino001/set/luzpuerta"
   payload_on: "1"
   payload_off: "0"
   qos: 0
   retain: true
Responder
#5
(01-20-2019, 02:37 PM)Latibon escribió:
(01-20-2019, 11:33 AM)javiermb escribió:
(01-20-2019, 09:46 AM)Latibon escribió: Hola Javier.

Todos en algun momento hemos pasado por tu estado de ánimo o al menos parecido, porque todos nos hemos encontrado con problemas desesperantes. Pero al final siempre se encuentra la solución y tu caso no va a ser menos.

Me gustaría que pusieras el archivo switch.yaml entero tal como lo tienes ahora, o al menos cópialo aquí desde la primera línea a la última.

Gracias Latibon.

La ultima configuracion del archivo switch.yaml es la que pegue en mi primer comentario y ahi me quede.

Gracias de nuevo.

Si tienes bien declarado el switch.yaml en el configuration.yaml con el correspondiente include, y el switch.yaml solo tiene lo que has puesto aquí, debería funcionar correctamente.

Te paso como debería quedar. Copialo tal cual respetando los espacios.



Código:
 - platform: mqtt
   name: “Lampara”
   state_topic: "domuino001/get/luzmesa"
   command_topic: "domuino001/set/luzmesa"
   payload_on: "1"
   payload_off: "0"
   qos: 0
   retain: true

 - platform: mqtt
   name: “Puerta”
   state_topic: "domuino001/get/luzpuerta"
   command_topic: "domuino001/set/luzpuerta"
   payload_on: "1"
   payload_off: "0"
   qos: 0
   retain: true
Pues amigo......no se como agradecertelo, pero ha funcionado, y rete-mirando el fallo esta en muchos copia y pega en los cuales el guion de platform estaba pegado al mismo.

Un millon de gracias.
Responder
#6
(01-20-2019, 03:27 PM)javiermb escribió:
(01-20-2019, 02:37 PM)Latibon escribió:
(01-20-2019, 11:33 AM)javiermb escribió:
(01-20-2019, 09:46 AM)Latibon escribió: Hola Javier.

Todos en algun momento hemos pasado por tu estado de ánimo o al menos parecido, porque todos nos hemos encontrado con problemas desesperantes. Pero al final siempre se encuentra la solución y tu caso no va a ser menos.

Me gustaría que pusieras el archivo switch.yaml entero tal como lo tienes ahora, o al menos cópialo aquí desde la primera línea a la última.

Gracias Latibon.

La ultima configuracion del archivo switch.yaml es la que pegue en mi primer comentario y ahi me quede.

Gracias de nuevo.

Si tienes bien declarado el switch.yaml en el configuration.yaml con el correspondiente include, y el switch.yaml solo tiene lo que has puesto aquí, debería funcionar correctamente.

Te paso como debería quedar. Copialo tal cual respetando los espacios.



Código:
 - platform: mqtt
   name: “Lampara”
   state_topic: "domuino001/get/luzmesa"
   command_topic: "domuino001/set/luzmesa"
   payload_on: "1"
   payload_off: "0"
   qos: 0
   retain: true

 - platform: mqtt
   name: “Puerta”
   state_topic: "domuino001/get/luzpuerta"
   command_topic: "domuino001/set/luzpuerta"
   payload_on: "1"
   payload_off: "0"
   qos: 0
   retain: true
Pues amigo......no se como agradecertelo, pero ha funcionado, y rete-mirando el fallo esta en muchos copia y pega en los cuales el guion de platform estaba pegado al mismo.

Un millon de gracias.

Me alegro de que haya funcionado.
Ya sabes, no desesperes que la mayoría de las veces es una chorrada que no vemos. ;-)
Responder
#7
La parte de retain la podeis quitar, no funciona bien porque no debe estar configurado en domuino, de echo podeis probar a reiniciar home assistant y vereis como no recupera el estado.
Responder
#8
Buenas chicos ,este hilo lo abrí hace tiempo pero por falta de tiempo lo deje pasar ,lo he vuelto ha retomar sin éxito haber si me podéis echar una mano. El tema es no conecto con MQTT, yo creo que lo he echo todo ya os mando capturas. Me pasa con todas las placas

QTT 192.168.1.64 connecting...
failed, rc=5
18:9:39 Rx: 192.168.1.130(2015): 255,112,6,0,96,15,24,36,32,
18:9:39 Send 192.168.1.130 (2015) 6,119,3,0,21,0,2,0,0,0,6,122,30,0,0,0,0,
* 18:9:43 RAM: 34440 / CPU:2% / I Util: 29996 Err Rx/Tx: Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5
18:10:9 Rx: 192.168.1.130(2015): 255,112,6,0,126,15,24,36,62,
18:10:9 Send 192.168.1.130 (2015) 6,119,3,0,21,0,2,0,0,0,6,122,30,0,0,0,0,
* 18:10:13 RAM: 34384 / CPU:0% / I Util: 30000 Err Rx/Tx: Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5
18:10:39 Rx: 192.168.1.130(2015): 255,112,6,0,156,15,24,36,92,
18:10:39 Send 192.168.1.130 (2015) 6,119,3,0,21,0,2,0,0,0,6,122,30,0,0,0,0,
* 18:10:43 RAM: 34328 / CPU:0% / I Util: 30001 Err Rx/Tx: Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5
18:11:9 Rx: 192.168.1.130(2015): 255,112,6,0,186,15,24,36,122,
18:11:9 Send 192.168.1.130 (2015) 6,119,3,0,21,0,2,0,0,0,6,122,30,0,0,0,0,
* 18:11:13 RAM: 34272 / CPU:2% / I Util: 29994 Err Rx/Tx: Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5
18:11:23 Rx: 192.168.1.102(48294): 3,112,255,96,76,97,25,36,188,
1 Add IP 192.168.1.102 (48294) UnitId: 255
18:11:23 Send 192.168.1.102 (48294) 255,119,3,96,21,0,2,0,0,0,6,122,30,0,0,0,0,
18:11:23 Rx: 192.168.1.102(48294): 3,102,255,100,0,0,0,1,58,90,243,181,186,145,111,20,249,246,198,154,35,153,87,138,200,115,106,158,6,
18:11:23 [0] Salida Pin 2 = 1
18:11:23 Send 192.168.1.102 (48294) 255,102,3,100,3,0,0,0,0,0,73,0,1,
18:11:23 Send 192.168.1.102 (48294) 255,113,3,0,3,0,0,0,0,0,73,0,1,
18:11:25 Rx: 192.168.1.102(48294): 3,102,255,106,0,0,0,0,161,63,113,0,121,220,176,48,150,99,148,9,180,112,15,81,58,204,12,25,157,
18:11:25 [0] Salida Pin 2 = 0
18:11:25 Send 192.168.1.102 (48294) 255,102,3,106,4,0,0,0,0,0,80,0,0,
18:11:25 Send 192.168.1.102 (48294) 255,113,3,0,4,0,0,0,0,0,80,0,0,
18:11:27 Rx: 192.168.1.102(48294): 3,112,255,114,80,97,25,36,210,
18:11:27 Send 192.168.1.102 (48294) 255,119,3,114,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:11:32 Rx: 192.168.1.102(48294): 3,112,255,136,85,97,25,36,237,
18:11:32 Send 192.168.1.102 (48294) 255,119,3,136,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:11:37 Rx: 192.168.1.102(48294): 3,112,255,155,90,97,25,36,5,
18:11:37 Send 192.168.1.102 (48294) 255,119,3,155,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:11:39 Rx: 192.168.1.130(2015): 255,112,6,0,216,15,24,36,152,
18:11:39 Send 192.168.1.130 (2015) 6,119,3,0,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:11:42 Rx: 192.168.1.102(48294): 3,112,255,173,95,97,25,36,28,
18:11:42 Send 192.168.1.102 (48294) 255,119,3,173,21,0,4,0,0,0,6,122,30,0,0,0,0,
* 18:11:43 RAM: 34192 / CPU:2% / I Util: 29956 Err Rx/Tx: Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5
18:11:47 Rx: 192.168.1.102(48294): 3,112,255,191,100,97,25,36,51,
18:11:47 Send 192.168.1.102 (48294) 255,119,3,191,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:11:52 Rx: 192.168.1.102(48294): 3,112,255,209,106,97,25,36,75,
18:11:52 Send 192.168.1.102 (48294) 255,119,3,209,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:12:9 Rx: 192.168.1.130(2015): 255,112,6,0,246,15,24,36,182,
18:12:9 Send 192.168.1.130 (2015) 6,119,3,0,21,0,4,0,0,0,6,122,30,0,0,0,0,
* 18:12:13 RAM: 34136 / CPU:2% / I Util: 29991 Err Rx/Tx: Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5 ( IDE ARDUINO)

1552323459: Socket error on client <unknown>, disconnecting.
1552323482: New connection from 192.168.1.20 on port 1883.
1552323482: Socket error on client <unknown>, disconnecting.
1552323666: New connection from 192.168.1.20 on port 1883.
1552323666: Socket error on client <unknown>, disconnecting.
1552323691: New connection from 192.168.1.20 on port 1883.
1552323691: Socket error on client <unknown>, disconnecting.
1552323828: New connection from 192.168.1.20 on port 1883.
1552323828: Socket error on client <unknown>, disconnecting.
1552323853: New connection from 192.168.1.20 on port 1883.
1552323853: Socket error on client <unknown>, disconnecting.
1552323883: New connection from 192.168.1.20 on port 1883.
1552323883: Socket error on client <unknown>, disconnecting.
(HOMEASSISTANT)

#server mosquitto
mqtt:
broker: 192.168.1.64

switch 1:
- platform: mqtt
name: "LED PLACA"
state_topic: "domuino006/get/LED PLACA"
command_topic: "house/switch1"
payload_on: 1
payload_off: 0
qos: 0
retain: true
(CONFIGURATION YAML)

GRACIAS
Responder
#9
(03-13-2019, 06:39 AM)Miguel Ripol escribió: Buenas chicos ,este hilo lo abrí hace tiempo pero por falta de tiempo lo deje pasar ,lo he vuelto ha retomar sin éxito haber si me podéis echar una mano. El tema es no conecto con MQTT, yo creo que lo he echo todo ya os mando capturas. Me pasa con todas las placas

QTT 192.168.1.64 connecting...
failed, rc=5
18:9:39 Rx: 192.168.1.130(2015):  255,112,6,0,96,15,24,36,32,
18:9:39 Send 192.168.1.130 (2015)  6,119,3,0,21,0,2,0,0,0,6,122,30,0,0,0,0,
* 18:9:43 RAM: 34440 / CPU:2% / I Util: 29996 Err Rx/Tx:  Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5
18:10:9 Rx: 192.168.1.130(2015):  255,112,6,0,126,15,24,36,62,
18:10:9 Send 192.168.1.130 (2015)  6,119,3,0,21,0,2,0,0,0,6,122,30,0,0,0,0,
* 18:10:13 RAM: 34384 / CPU:0% / I Util: 30000 Err Rx/Tx:  Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5
18:10:39 Rx: 192.168.1.130(2015):  255,112,6,0,156,15,24,36,92,
18:10:39 Send 192.168.1.130 (2015)  6,119,3,0,21,0,2,0,0,0,6,122,30,0,0,0,0,
* 18:10:43 RAM: 34328 / CPU:0% / I Util: 30001 Err Rx/Tx:  Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5
18:11:9 Rx: 192.168.1.130(2015):  255,112,6,0,186,15,24,36,122,
18:11:9 Send 192.168.1.130 (2015)  6,119,3,0,21,0,2,0,0,0,6,122,30,0,0,0,0,
* 18:11:13 RAM: 34272 / CPU:2% / I Util: 29994 Err Rx/Tx:  Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5
18:11:23 Rx: 192.168.1.102(48294):  3,112,255,96,76,97,25,36,188,
1 Add IP 192.168.1.102 (48294)  UnitId: 255
18:11:23 Send 192.168.1.102 (48294)  255,119,3,96,21,0,2,0,0,0,6,122,30,0,0,0,0,
18:11:23 Rx: 192.168.1.102(48294):  3,102,255,100,0,0,0,1,58,90,243,181,186,145,111,20,249,246,198,154,35,153,87,138,200,115,106,158,6,
18:11:23 [0] Salida  Pin 2 = 1
18:11:23 Send 192.168.1.102 (48294)  255,102,3,100,3,0,0,0,0,0,73,0,1,
18:11:23 Send 192.168.1.102 (48294)  255,113,3,0,3,0,0,0,0,0,73,0,1,
18:11:25 Rx: 192.168.1.102(48294):  3,102,255,106,0,0,0,0,161,63,113,0,121,220,176,48,150,99,148,9,180,112,15,81,58,204,12,25,157,
18:11:25 [0] Salida  Pin 2 = 0
18:11:25 Send 192.168.1.102 (48294)  255,102,3,106,4,0,0,0,0,0,80,0,0,
18:11:25 Send 192.168.1.102 (48294)  255,113,3,0,4,0,0,0,0,0,80,0,0,
18:11:27 Rx: 192.168.1.102(48294):  3,112,255,114,80,97,25,36,210,
18:11:27 Send 192.168.1.102 (48294)  255,119,3,114,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:11:32 Rx: 192.168.1.102(48294):  3,112,255,136,85,97,25,36,237,
18:11:32 Send 192.168.1.102 (48294)  255,119,3,136,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:11:37 Rx: 192.168.1.102(48294):  3,112,255,155,90,97,25,36,5,
18:11:37 Send 192.168.1.102 (48294)  255,119,3,155,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:11:39 Rx: 192.168.1.130(2015):  255,112,6,0,216,15,24,36,152,
18:11:39 Send 192.168.1.130 (2015)  6,119,3,0,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:11:42 Rx: 192.168.1.102(48294):  3,112,255,173,95,97,25,36,28,
18:11:42 Send 192.168.1.102 (48294)  255,119,3,173,21,0,4,0,0,0,6,122,30,0,0,0,0,
* 18:11:43 RAM: 34192 / CPU:2% / I Util: 29956 Err Rx/Tx:  Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5
18:11:47 Rx: 192.168.1.102(48294):  3,112,255,191,100,97,25,36,51,
18:11:47 Send 192.168.1.102 (48294)  255,119,3,191,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:11:52 Rx: 192.168.1.102(48294):  3,112,255,209,106,97,25,36,75,
18:11:52 Send 192.168.1.102 (48294)  255,119,3,209,21,0,4,0,0,0,6,122,30,0,0,0,0,
18:12:9 Rx: 192.168.1.130(2015):  255,112,6,0,246,15,24,36,182,
18:12:9 Send 192.168.1.130 (2015)  6,119,3,0,21,0,4,0,0,0,6,122,30,0,0,0,0,
* 18:12:13 RAM: 34136 / CPU:2% / I Util: 29991 Err Rx/Tx:  Eth:0/0%
MQTT 192.168.1.64 connecting...
failed, rc=5 ( IDE ARDUINO)

1552323459: Socket error on client <unknown>, disconnecting.
1552323482: New connection from 192.168.1.20 on port 1883.
1552323482: Socket error on client <unknown>, disconnecting.
1552323666: New connection from 192.168.1.20 on port 1883.
1552323666: Socket error on client <unknown>, disconnecting.
1552323691: New connection from 192.168.1.20 on port 1883.
1552323691: Socket error on client <unknown>, disconnecting.
1552323828: New connection from 192.168.1.20 on port 1883.
1552323828: Socket error on client <unknown>, disconnecting.
1552323853: New connection from 192.168.1.20 on port 1883.
1552323853: Socket error on client <unknown>, disconnecting.
1552323883: New connection from 192.168.1.20 on port 1883.
1552323883: Socket error on client <unknown>, disconnecting.
(HOMEASSISTANT)

#server mosquitto
mqtt:
 broker: 192.168.1.64
 
switch 1:
 - platform: mqtt
   name: "LED PLACA"
   state_topic: "domuino006/get/LED PLACA"
   command_topic: "house/switch1"
   payload_on: 1
   payload_off: 0
   qos: 0
   retain: true
(CONFIGURATION YAML)

GRACIAS

No sé decirte por qué, pero el error RC=5 y el log de HA, te están diciendo que el host MQTT no permite la conexión de ese cliente.

¿Cuál es el cliente? ¿Tienes otro clientes conectados?
Responder
#10
Si cómo cliente te refieres a la máquina donde esta homeassistant, solo es una
Responder


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)