Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Programación hass.io
#1
Buenos días chicos, tras mucho meditarlo me he decidido por instalar homeassistant. Principalmente para no quedarme descolgado de este gran proyecto. Ahora vamos al lío!!!. Tengo un problema he estado trasteando mucho hasta conseguir poner un pulsador en hassio , ahora bien, seguro será tintada pero no consigo que poner dos, en configuración.yml pongo los dos y solo me aparece el último que configuro. También probé hacer lo que ya comentó un compañero en configurarlos seguidos en yml es decir sin poner siwch 1 siwch2 ect..... Pero nada. Ya me comentáis saludos
Responder
#2
Si pones aquí el yaml es más fácil ayudarte, pero casi seguro que tienes declarados dos switch.

Si pones los switch en el configuration.yaml, esta es la estructura:

switch:
- platform: mqtt
name: "Raspberry"
command_topic: "domuino010/set/Raspberry"
state_topic: "domuino010/get/Raspberry"
payload_on: "1"
payload_off: "0"
retain: false

- platform: mqtt
name: "Luz habitación"
command_topic: "domuino010/set/Luz_habitacion"
state_topic: "domuino010/get/Luz_habitacion"
payload_on: "1"
payload_off: "0"
retain: false


- platform: mqtt
name: "Luz cama"
command_topic: "domuino010/set/Luz_cama"
state_topic: "domuino010/get/Luz_cama"
payload_on: "1"
payload_off: "0"
retain: false

Edito para advertir que al publicar no respeta los espacios de la izquierda.
Responder
#3
de antemano gracias por la pronta respuesta ,aquí te dejo mi configuración ,como lo ves?

homeassistant:
 # Name of the location where Home Assistant is running
 name: CASA DOMOTICA MIGUEL Y ANA
 # Location required to calculate the time the sun rises and sets
 latitude: 41.645067971014306
 longitude: -0.8632031210419735
 # Impacts weather/sunrise data (altitude above sea level in meters)
 elevation: 0
 # metric for Metric, imperial for Imperial
 unit_system: metric
 # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_...time_zones
 time_zone: UTC
 # Customization file
 customize: !include customize.yaml

# Show links to resources in log and frontend
introduction:

# Enables the frontend
frontend:

# Enables configuration UI
config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/2...e-updater/
updater:
 # Optional, allows Home Assistant developers to focus on popular components.
 # include_used_components: true

# Discover some devices automatically
discovery:

# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:

# Weather prediction
sensor:
 - platform: yr

# Text to speech
tts:
 - platform: google

# Cloud
cloud:
 alexa:
   filter:
     include_entities:
       - light.kitchen
       - light.kitchen_left
     include_domains:
       - switch
     exclude_entities:
       - switch.outside
   entity_config:
     light.kitchen:
       name: Custom Name for Alexa
       description: The light in the kitchen
     switch.stairs:
       display_categories: LIGHT

#server mosquitto
mqtt :
broker : 192.168.1.12

#sensor domuino
sensor 2:
- platform: mqtt
 state_topic: "domuino003/get/ggvv"

#switch prueba 1
switch:
- platform: mqtt
 command_topic: "domuino003/set/pp"
 name: "pulsador"
 state_topic: "domuino003/get/pp"
 payload_on: "1"
 payload_off: "0"
 qos: 0
- platform: mqtt
 command_topic: "domuino003/set/pps"
 name: "pulsador"
 state_topic: "domuino003/get/pps"
 payload_on: "1"
 payload_off: "0"
 qos: 0
Responder
#4
Big Grin 
Yo lo que haría en primer lugar es quitar las coordenadas del mensaje, porque ahora ya podemos ir todos a comer a tu casa...   Big Grin Big Grin

Lo segundo que veo es que te falta el usuario y el password del servicio MQTT, aunque si dices que uno de los pulsadores funciona, quizá es que lo hayas borrado para pegarlo aquí.

Lo tercero y lo que te tiene preocupado es.... que no puedes llamar a los dos switch igual. Cambia el nombre de uno de los dos, y suponiendo que los espacios están correctos, debería funcionar.

Ya me cuentas.
Responder
#5
Jijiji, podéis venir todos a comer si queréis. No enserio, es todo pruebas los datos no son los reales. Por eso también no tengo la clave en MQTT. CON, con respecto a lo que me comentas. He probado con varios nombres distintos por si era eso pero nada, siempre graba el último. Tampoco lo he borrado al grabarbborradoborrado

Perdón, quería decir que tampoco lo he borrado al pegarlo aquí, así que me tiene mosqueado, no sé qué puede ser
Responder
#6
Los nombre de los dos pulsadores no pueden ser iguales.
Responder
#7
Muchas gracias latibon, tan sencillo como eso. Funcionando correctamente. Lo que he notado ahora es mucha desconexión de MQTT y domuino Cusco grabas. Hay que resetear mucho el hardware,y a veces ni eso no sé si os pasará lo mismo. De nuevo gracias
Responder


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)