Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
APP 3.6.6
#1
3.6.6 - Corrección de errores recibidos por correo. Gracias a todos los que colaboráis.

        Hay algún error que me haría falta saber que es lo que se esta haciendo cuando da el error.

3.6.5 - Arreglado error cuando se creaba una escena sin elementos.

      - Arreglado error al recuperar copia de seguridad, en la lista de dispositivos si se recuperaba antes un icsc que el ruter.
      - Arreglado permita forzar borrado de dispositivos con elementos usados por otro dispositivo. (¡¡¡No es aconsejable!!!)

3.6.3 

      - cambiada vista botones en la escenas para que sean toogle

      - Añadido boton de envio en acciones, escenas y comandos.
      - Arreglado bug con los remotos en escenas


Archivos adjuntos
.zip   app-release (61).zip (Tamaño: 5.78 MB / Descargas: 57)
Responder
#2
3.5 - Modificada la actualización de las versiones y copias de seguridad, tiene en cuenta si es
una versión anterior, si ya usa cifrado o no, los campos que debería tener, etc.
- Añadido que si se cambian de bus los dispositivos, modifique los cambios en los elementos remotos y actualize los arduinos.
- vista create_update_disposititvo, cuando se cambiaba de icsc a ethernet no mostraba bien la vista y no modificaba bien los valores y se quedaba como icsc.
- la lista de dispositivos puede verse desordenada porque antes ordenaba por id y ahora ordena por bus de menor a mayor.

3.5.1 - Error en insert bulk en elementos si el nombre es null daba error.

3.6 - Añadido soporte multi idioma, por defecto en Ingles, y según configuración del dispositivo móvil, Español.
- Añadido corrección de error al editar un ciclo de riego, una etapa o una escena, si en la lista de elementos hay algún elemento
remoto que apunta a algún bus que no existe, para que no cargue ese elemento.

3.6.1 - Añadido posibilidad de setear valor al editar las escenas en la lista de elementos

3.6.2 - Arreglado error en las escenas no seteaba bien el valor en los remotos

3.6.4 - Modificado que cuando se utilizan remotos en listas, no se borren y creen si es el mismo.
- Añadido que cada vez que manda un comando borre la cola de oks recibidos.
Responder
#3
(07-05-2016, 06:53 PM)Monly escribió: 3.5   - Modificada la actualización de las versiones y copias de seguridad, tiene en cuenta si es
        una versión anterior, si ya usa cifrado o no, los campos que debería tener, etc.
      - Añadido que si se cambian de bus los dispositivos, modifique los cambios en los elementos remotos y actualize los arduinos.
    - vista create_update_disposititvo, cuando se cambiaba de icsc a ethernet no mostraba bien la vista y no modificaba bien los valores y se quedaba como icsc.
    - la lista de dispositivos puede verse desordenada porque antes ordenaba por id y ahora ordena por bus de menor a mayor.

3.5.1 - Error en insert bulk en elementos si el nombre es null daba error.

3.6  - Añadido soporte multi idioma, por defecto en Ingles, y según configuración del dispositivo móvil, Español.
    - Añadido corrección de error al editar un ciclo de riego, una etapa o una escena,  si en la lista de elementos hay algún elemento
      remoto que apunta a algún bus que no existe, para que no cargue ese elemento.

3.6.1 - Añadido posibilidad de setear valor al editar las escenas en la lista de elementos

3.6.2 - Arreglado error en las escenas no seteaba bien el valor en los remotos

3.6.4 - Modificado que cuando se utilizan remotos en listas, no se borren y creen si es el mismo.
     - Añadido que cada vez que manda un comando borre la cola de oks recibidos.

te lo has currado +1
Responder
#4
Gracias por la actualización!!!!, con esta version también esta corregido el retardo que se producía en los esclavos ICSC y el correspondiente refresco del estado en la APP?

Saludos
Responder
#5
Ayer cargue la aplicación, estoy probando los cambios ire reportando lo que vaya encontrando.

Al actualizar sin des instalar la versión anterior, se instala correctamente, pero los elemento del menú principal se descuadran y aparecen en otras categorias. Me parece un error menor, tampoco tarde mucho en volver a colocarlo todo.

De momento probando la funcionalidad principal y todo ok.
Responder
#6
(07-06-2016, 06:31 AM)db25 escribió: Gracias por la actualización!!!!, con esta version también esta corregido el retardo que se producía en los esclavos ICSC y el correspondiente refresco del estado en la APP?

Saludos

No se nada del tema de los retardos que comentas.
Te funcionaba bien una versión anterior y ahora no refresca bien?
Actualizaste el código de los arduinos, o es con el mismo.

Lo único que te puedo decir es que habían errores con los remotos, si utilizabas remotos por icsc pues igual viene por hay el problema.
Responder
#7
Hola Monly, cuando actualice el ultimo código que publico Almagar (0.78) note una caída en el rendimiento de los esclavos ICSC, tardaban mucho en ejecutar las ordenes (hacen huso de elementos remotos), ademas la APP tardaba mucho en refrescar el estado, por lo que tuve que volver atrás. Sin embargo para los ESP o elementos wifi mejoro bastante el rendimiento. Actualmente he vuelto a versiones bastante antiguas porque con ellas me funcionaba todo correctamente, escenas, horarios, reloj, etc.

Aun así instalare la APP en el movil de la chica y haré pruebas con ella en la maqueta, aunque no podrán ser tan exhaustivas como en la instalación real ya que el numero de elementos y dispositivos es mucho menor.

Comentare los resultados, saludos!!!
Responder
#8
Buenas Tardes,

Esta actualización me viene como agua de Mayo, estaba a punto de borrarlo todo y empezar de 0, creo que he mandado unos cuantos reportes de error. Mi problema era el siguiente:

En un UNO (Esclavo ICSC), cree una programación ciclica, es decir una salida y un control digital para que arranque uno cuando el otro se pare, es la forma que encontré para encender un dispositivo un tiempo especifico en intervalos. De manera provisional lo hice para vaciar el deposito del pinguino ya que tenia pendiente conectar los sensores que lleva. El caso es que desde que lo cree la APP se reiniciaba constantemente, para actuar sobre otro Arduino con apagar este dispositivo se medio arreglaba el problema. El caso es que antes de ver la actualización he borrado la EEPROM y he vuelto a crear todo de 0, después de actualizar y poner todo como debe esta funcionando OK. Así que mil Gracias.
Responder
#9
(07-06-2016, 11:08 AM)db25 escribió: Hola Monly, cuando actualice el ultimo código que publico Almagar (0.78) note una caída en el rendimiento de los esclavos ICSC, tardaban mucho en ejecutar las ordenes (hacen huso de elementos remotos), ademas la APP tardaba mucho en refrescar el estado, por lo que tuve que volver atrás. Sin embargo para los ESP o elementos wifi mejoro bastante el rendimiento. Actualmente he vuelto a versiones bastante antiguas porque con ellas me funcionaba todo correctamente, escenas, horarios, reloj, etc.

Aun así instalare la APP en el movil de la chica y haré pruebas con ella en la maqueta, aunque no podrán ser tan exhaustivas como en la instalación real ya que el numero de elementos y dispositivos es mucho menor.

Comentare los resultados, saludos!!!

hola que versión antigua estas usando?
Responder
#10
Pues he vuelto a la version en la que había que configurar salidas remotas ( Confused Confused ), porque la version 0.78 no me iba muy fina con los esclavos ICSC y con la 0.77 no se sincronizan bien el reloj en los esclavos ICSC y esto me afecta a las programaciones.
Responder


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)